Northern California wildfires causing disruption to postal operations in some areas
Incident Report for Shipwire
Resolved
Carriers are now conducting standard daily operations in Northern California. Previous hazardous conditions across the area have subsided and carriers are now back to standard daily operations. Note that some isolated areas remain inaccessible and there may be on-going service delays due to local conditions.
Posted 9 months ago. Oct 27, 2017 - 17:49 PDT
Monitoring
Wildfires in N. California have halted postal operations in nearby areas. Delivery is being attempted where it is safe for both customers and employees.
Posted 9 months ago. Oct 16, 2017 - 14:59 PDT
This incident affected: Carriers (DHL eCommerce (Global Mail), FedEx, UPS, USPS).