Some orders scheduled to ship on July 18th out of New Lenox, IL are delayed.
Resolved
All of the impacted orders will ship out by end of day, July 20, 2017.
Posted Jul 20, 2017 - 11:18 PDT
Identified
An order transmission error has caused 342 orders at the New Lenox, IL warehouse not to ship out as scheduled on July 18, 2017. We are working on updating these orders so they ship out tomorrow, July, 20, 2017.
Posted Jul 19, 2017 - 14:16 PDT
This incident affected: Warehouses (New Lenox, IL).