Orders from the Tilburg, NLD warehouse are shipping out with an average 2 day delay
Incident Report for Shipwire
Resolved
All orders from last week have shipped.
Posted 5 months ago. Dec 04, 2017 - 11:03 PST
Monitoring
Due to peak season volume exceeding what was forecasted for Black Friday, Cyber Monday and Cyber Week, the Tilburg, NLD warehouse has delayed order processing. On average, orders are shipping out 2 days later than expected. The Tilburg, NLD warehouse anticipates being able to resume regular processing SLA by Monday, December 4th, 2017.

We appreciate your patience as we work diligently to resolve these delays. For any questions or concerns, please email customercare@ingrammicrocommerce.com.
Posted 5 months ago. Nov 29, 2017 - 12:49 PST
This incident affected: Warehouses (Tilburg, NLD).