Shipping delay for orders placed on December, 1, 2017 out of Tin Shui Wai, HKG warehouse
Incident Report for Shipwire
Resolved
All impacted orders were shipped out on Monday, December 4, 2017.
Posted about 2 months ago. Dec 04, 2017 - 10:58 PST
Monitoring
An order processing error has impacted 834 orders that were scheduled to ship out of the Tin Shui Wai, HKG warehouse today. The issue is being addressed and orders are expected to be shipped on Monday, December 4th, 2017.
Posted about 2 months ago. Dec 01, 2017 - 12:28 PST
This incident affected: Warehouses (Tin Shui Wai, HKG).