Lancaster Warehouse - Weather
Incident Report for Shipwire
Resolved
Normal operating conditions today, Wednesday 3/15/17. Carriers will be making scheduled pickups. No delays expected today.
Posted 9 months ago. Mar 15, 2017 - 06:36 PDT
Monitoring
The Lancaster area is receiving a significant amount of snow. Delays in order processing are expected.
Posted 9 months ago. Mar 14, 2017 - 06:26 PDT
This incident affected: Warehouses (Lancaster, PA, Jonestown, PA).