Canada Post Service Delay due to high Volume
Incident Report for Shipwire
Resolved
Canada Post is still reporting delivery delays of 1 day for the Toronto and Montreal areas. Please check with Canada Post for updates and expected delivery times- https://www.canadapost.ca
Posted 7 months ago. Dec 04, 2017 - 11:06 PST
Monitoring
Canada Post continues to experience delays due to high volumes earlier this week. Deliveries to Toronto and Montreal are expected to be delivered 1 day late.

We appreciate your patience as we work diligently to resolve these delays. For any questions or concerns, please email customercare@ingrammicrocommerce.com.
Posted 8 months ago. Dec 01, 2017 - 15:04 PST
Identified
Cyber Monday and Cyber Week promotions have significantly increased the volume of parcels in our network last night. We expect very high parcel volumes all week. We now expect a delay in delivering parcels in the Toronto and Montreal areas for today
Posted 8 months ago. Nov 28, 2017 - 12:34 PST
This incident affected: Carriers (Canada Post) and Warehouses (Mississauga, CAN, Richmond, CAN).