Hurricane Maria carrier outages
Resolved
Carriers are now conducting standard daily operations in the south central and southeastern regions of the U.S., and most areas of the U.S. Virgin Islands and Puerto Rico recently affected by Hurricanes Maria, Irma, and Harvey. Previous hazardous conditions across the areas have subsided, and carriers are now back to standard daily operations.
Note that some isolated areas in the U.S. Virgin Islands and Puerto Rico remain inaccessible because of local conditions.
Posted Oct 13, 2017 - 17:40 PDT
Monitoring
All major carriers are suspending service to the U.S. Virgin Islands and Puerto Rico as a result of the damage caused by Hurricane Maria. At this time, there is no estimate on when service will resume.
Posted Sep 21, 2017 - 13:44 PDT
This incident affected: Carriers (Canada Post, DHL eCommerce (Global Mail), FedEx, Purolator, UPS, USPS).