ASN/Receiving label - Broken download link
Resolved
The download link for ASN/Receiving labels is now working again. We expect no further issues moving forward.
Posted Jun 20, 2017 - 15:14 PDT
Identified
Our team has uncovered that the download link for ASN/Receiving labels are currently broken. This was a result of a recent change in our content management system. We are currently working on fixing these links as soon as possible. Please stay tuned for further updates.
Posted Jun 20, 2017 - 12:29 PDT