Eastern Creek, AUS - Missed shipping windows due to unexpected order volume
Incident Report for Shipwire
Resolved
Our team has caught up on processing the delayed orders and expect no further issues moving forward.
Posted 2 months ago. Jun 15, 2017 - 15:23 PDT
Monitoring
Our team has caught up on a majority of the delayed orders today with only 2 left scheduled to ship tomorrow. We expect no further issues moving forward.
Posted 2 months ago. Jun 14, 2017 - 16:34 PDT
Identified
Our Eastern Creek, AUS fulfillment center saw an unexpected spike in order volume today. Because of this, we have missed the July 13th (6/13) shipping window service level agreement for about 30 merchants and their orders. We will be promptly sending those orders out for tomorrow, July 14th (6/14).
Posted 2 months ago. Jun 13, 2017 - 15:52 PDT
This incident affected: Warehouses (Eastern Creek, AUS).