Sales and support e-mails not delivered over the weekend
Resolved
This incident has been resolved.
Posted Jul 10, 2017 - 13:44 PDT
Monitoring
An undetected issue with our Salesforce e-mail gateway delayed the delivery of messages bound for our Sales and Customer Success teams between Saturday July 8th and the morning of July 10th, Pacific time.

The issue has been resolved and e-mails are now processing normally.
Posted Jul 10, 2017 - 10:54 PDT