FedEx Service Delays Across the U.S.
Resolved
This incident has been resolved.
Posted Mar 09, 2021 - 10:29 PST
Update
Previous hazardous conditions across the U.S. have subsided and FedEx is now back to standard daily operations. Please be advised that there may be on-going service delays until recovery efforts conclude across the country.
Posted Mar 03, 2021 - 10:21 PST
Update
Due to the severe weather events and hazardous conditions across the U.S., service delays for pickups and deliveries throughout the U.S are expected.

To see the current cities and zip codes impacted, please go to https://www.fedex.com/en-us/service-alerts.html#weather.
Posted Mar 01, 2021 - 09:42 PST
Update
Due to severe weather events across the U.S. on Saturday, 2/20/21, there are substantial disruptions at the FedEx Memphis Hub. Please expect delays in deliveries throughout the U.S.

To see the current cities and zip codes impacted, please go to https://www.fedex.com/en-us/service-alerts.html#weather.
Posted Feb 22, 2021 - 10:35 PST
Update
Due to a national service disruption at FedEx’s Memphis hub last night, please continue to expect 1-2 day delays throughout FedEx’s network until further notice. With the hazardous weather conditions spanning the U.S., package deliveries are being significantly impacted.

To see the current cities and zip codes impacted, please go to https://www.fedex.com/en-us/service-alerts.html#weather.
Posted Feb 17, 2021 - 10:49 PST
Update
Due to continued severe weather events across the U.S., there are ongoing disruptions in several FedEx Hubs. Please anticipate FedEx service delays of 1-2 days within the following U.S. States: Arkansas, Idaho, Massachusetts, Missouri, Oklahoma, Oregon, Tennessee, Texas and Washington.

We will continue to provide updates as more information becomes available.
Posted Feb 16, 2021 - 11:22 PST
Update
Due to severe weather events across the U.S. on Saturday, 2/13/21, there are substantial disruptions at the FedEx Memphis Hub. Please expect delays in deliveries throughout the U.S.

To see the current cities and zip codes impacted, please go to https://www.fedex.com/en-us/service-alerts.html#weather.
Posted Feb 15, 2021 - 10:04 PST
Monitoring
Due to winter storms creating hazardous conditions across the U.S., service delays and disruptions can be anticipated for FedEx inbound and outbound shipments across the U.S.

To see the current cities and zip codes impacted, please go to https://www.fedex.com/en-us/service-alerts.html#weather.
Posted Feb 04, 2021 - 10:34 PST
This incident affected: Carriers (FedEx).