Reno, Nevada Warehouse Delays
Resolved
This incident has been resolved.
Posted Jun 01, 2022 - 10:35 PDT
Update
Please be advised that our Reno, NV facility continues to experience delays in both inbound processing and outbound order fulfillment due to the fire in the area and expects delays to continue for the rest of the week. They are working through orders on a first in first out basis.
Posted May 03, 2022 - 09:42 PDT
Monitoring
Please be advised of order delays out of our Reno, Nevada facility due to a fire in the vicinity. We will continue to monitor and update.
Posted May 02, 2022 - 13:39 PDT
This incident affected: Warehouses (Reno, NV).