Laughton-Lewes, GBR (AFM)- Disabled Hermes Standard Services (HMS GD)
Resolved
This incident has been resolved.
Posted Jun 01, 2022 - 10:35 PDT
Identified
May 20, 2022

It is to inform that Hermes Standard (HMS GD) service will be disabled out from Laughton-Lewes, GBR (AFM) due to its service is unable to meet the satisfaction.

Should you have any questions, please contact customercare@ingrammicroservices.com
Posted May 20, 2022 - 13:28 PDT
This incident affected: Carriers (Hermes) and Warehouses (Laughton-Lewes, GBR).