GLS Orders Held in our Waalwijk, Netherlands Facility
Resolved
This incident has been resolved.
Posted Jun 08, 2021 - 14:45 PDT
Update
Please be aware that until further notice, GLS will be unavailable to EU territories that require a commercial invoice. We are actively working on a solution that will allow GLS to be able to ship to those locations and DHL Express is available as an alternative service. We will continue to provide updates as they are available.
Posted May 10, 2021 - 15:37 PDT
Monitoring
GLS orders that require a commercial invoice set to be shipped to EU territories will be held at our Waalwijk, Netherlands facility until early next week. We are actively working to allow for these shipments to be released from the warehouse. We are closely monitoring this situation and will continue to provide updates.
Posted May 04, 2021 - 10:58 PDT
This incident affected: Carriers (GLS (Netherlands)) and Warehouses (Waalwijk, NLD).