Shenzhen Orders delayed in customs
Resolved
This incident has been resolved.
Posted Dec 12, 2019 - 10:29 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 12, 2019 - 10:18 PST
Investigating
Shipments from August 27th are currently pending Shenzhen customs inspection. Our team is actively working with customs to release the shipments and will provide updates as we receive them. We apologize for any inconvenience this may cause and thank you for your patience. For questions or concerns, please contact customercare@ingrammicroservices.com.
Posted Sep 05, 2019 - 09:45 PDT
This incident affected: Warehouses (Shenzhen, CHN).