Australia Post Tracking Issues
Resolved
This incident has been resolved.
Posted Oct 21, 2020 - 12:58 PDT
Monitoring
Please be advised that Australia Post is currently experiencing internal data issues that may impact the tracking of parcel shipments. There is no impact to parcel processing or delivery, only tracking and notifications. Australia Post is working diligently to resolve this issue and we will update as soon as the issue is closed out.
Posted Oct 21, 2020 - 10:36 PDT
This incident affected: Carriers (Australia Post) and Warehouses (Eastern Creek, AUS).