GLS is Temporarily Disabled to Norway and Switzerland
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted Apr 06, 2021 - 15:38 PDT
Monitoring
Due to systematic disruptions, GLS inbound and outbound shipments are currently disabled to Norway and Switzerland until further notice. DHL Express will still be available. We will continue to provide updates as this situation evolves.
Posted Mar 15, 2021 - 09:02 PDT
This incident affected: Carriers (DHL Express, GLS (Netherlands)).