Fulfillment Delays Across Warehouse Network
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 09:36 PDT
Identified
Please be advised that we are experiencing fulfillment delays at many of our fulfillment centers due to COVID-19 related impacts on labor forces. Our top priority is the health and safety of our associates and our efforts remain committed to servicing your business to the best of our ability.
Posted Jan 07, 2022 - 13:54 PST
This incident affected: Warehouses (Rancho Cucamonga, Mira Loma, CA, Carrollton, TX, Millington, TN, Carol Stream, IL, New Lenox, IL, Lancaster, PA, Jonestown, PA, Tilburg, NLD, Laughton-Lewes, GBR, Shenzhen, CHN, Mississauga, CAN, Richmond, CAN, Eastern Creek, AUS, Hermosa, CA, Daventry, GBR, Waalwijk, NLD, Reno, NV).