USPS Announced Modified Schedule for Wednesday, December 5th
Incident Report for Shipwire
Resolved
USPS has resumed all deliveries.
Posted about 2 months ago. Dec 06, 2018 - 10:03 PST
Identified
On Wednesday, December 5th the U.S. Post Office will be honoring former President George H.W. Bush. As such the following modifications will be made to regular activity: All Post Office® locations will be closed, regular mail will not be delivered, and package delivery will be limited.

To read more about the service, please check your local news outlet or visit https://www.usps.com/national-day-of-mourning/welcome.htm
Posted about 2 months ago. Dec 04, 2018 - 08:01 PST
This incident affected: Carriers (USPS).