Postpone Inbound Deliveries Until After Sep 5th - Waalwijk, Netherlands
Resolved
This incident has been resolved.
Posted Nov 14, 2022 - 10:19 PST
Monitoring
Please be advised that our Waalwijk, Netherlands warehouse cannot accept any more inbound deliveries until after September 5th due to space constraints. Please reschedule all inbound deliveries for after September 5th for when we will have access to a storage extension.
Posted Aug 24, 2022 - 09:16 PDT
This incident affected: Warehouses (Waalwijk, NLD).