Beta Maintenance October 11, 2018 at 10 p.m. PST
Resolved
This incident has been resolved.
Posted Oct 30, 2018 - 13:02 PDT
Identified
Our engineering team will be performing maintenance on our Beta environment tonight. Testing in Beta during this time may be affected, however we expect the downtime to be no longer than 15 minutes. We apologize for any inconvenience this may cause.
Posted Oct 11, 2018 - 15:32 PDT
This incident affected: Merchant portal (Beta).