Delays due to Weather Conditions in Spain
Resolved
This incident has been resolved.
Posted Jan 26, 2021 - 12:22 PST
Update
GLS has resumed delivery to the regions in Spain in which they weren’t able to deliver last week due to heavy snowfall. However, you may experience continued delays in deliveries due to the large volume of shipments. We will continue to monitor the situation and provide updates accordingly.
Posted Jan 19, 2021 - 09:03 PST
Monitoring
Due to extreme weather conditions in Spain, you may experience delays in deliveries. Delays are heightened in the following areas, as deliveries are not currently possible: Madrid, Toledo, Albacete, Guadalajara, Cuenca and Teruel.

We are closely monitoring the situation and will continue to keep you updated as more information becomes available.
Posted Jan 13, 2021 - 10:58 PST
This incident affected: Carriers (Asendia, Australia Post, Canada Post, DHL eCommerce (Global Mail), DHL Express, DPD, FedEx, GLS (Netherlands), Hermes, Hong Kong Post, Netherlands Post, Purolator, Parcel Force, Royal Mail, StarTrack, Toll, Yodel, ABM) and Warehouses (Rancho Cucamonga, Mira Loma, CA, Carrollton, TX, Millington, TN, Carol Stream, IL, New Lenox, IL, Lancaster, PA, Jonestown, PA, Tilburg, NLD, Laughton-Lewes, GBR, Shenzhen, CHN, Mississauga, CAN, Richmond, CAN, Eastern Creek, AUS, Hermosa, CA, Daventry, GBR, Waalwijk, NLD).