Limited Warehouse Operations due to Weather Events
Resolved
This incident has been resolved.
Posted Mar 09, 2021 - 10:29 PST
Monitoring
Due to severe weather events, our Jonestown, PA facility is operating with limited capacity both inbound and outbound. At this time there are currently no FedEx Ground or Air pickups from our Jonestown, PA facility. Please be advised that delays in deliveries will occur.

We are monitoring this situation closely and will continue to provide updates as more information becomes available.
Posted Feb 18, 2021 - 14:49 PST
This incident affected: Carriers (FedEx) and Warehouses (Jonestown, PA).