FedEx New Residential COVID-19 Surcharge
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted Feb 25, 2021 - 11:06 PST
Monitoring
Please be advised that FedEx has added a new residential COVID-19 surcharge that will go into effect on Monday, February 15, 2021. The new residential COVID-19 surcharge is $0.30 per package and will apply to FedEx Express and FedEx Ground U.S. domestic residential packages (excluding FedEx SmartPost® and FedEx One Rate® packages).

Please visit https://www.fedex.com/en-us/shipping/current-rates/surcharges-and-fees.html for more information. You will see this reflected in the Shipwire Platform on Monday, February 15, 2021.
Posted Jan 29, 2021 - 14:36 PST
This incident affected: Carriers (FedEx).