Delays due to Weather Conditions in the Netherlands and Belgium
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted Feb 16, 2021 - 15:57 PST
Monitoring
Due to extreme weather conditions in the Netherlands and Belgium, please expect delays in deliveries across all carriers over the next few days. We are actively monitoring this situation and will continue to provide updates as more information becomes available.
Posted Feb 08, 2021 - 10:55 PST
This incident affected: Warehouses (Tilburg, NLD, Waalwijk, NLD).