Peak Carrier Delivery Delays
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 12:15 PDT
Monitoring
Although Ingram Micro ALC facilities continue to push through all of the volume, carriers are experiencing challenges inducting packages at the same rate into their facilities, which may show a delay in tracking movement on carrier websites.

In addition to carrier pick-up constraints, carriers are experiencing challenges getting all packages delivered in a timely fashion to some of their destination facilities. Current carrier challenges may cause an additional day delay in delivery.

Some partners may experience delivery delays with some packages up to 1 additional day in transit.

Ingram Micro Transportation continues to diligently work with carriers on all opportunities to mitigate delays.
Posted Dec 12, 2019 - 10:29 PST