Lancaster, PA: Outbound Delays
Resolved
This incident has been resolved.
Posted Dec 28, 2021 - 08:34 PST
Monitoring
Please be advised that we are continuing to see heavy inbound volumes at the Lancaster, PA warehouse. The continued increase of inbound volumes have created space and equipment constraints that are impacting outbound shipments. Please anticipate outbound order delays of 4 days.
Posted Nov 09, 2021 - 13:55 PST
This incident affected: Warehouses (Lancaster, PA).