Reno, NV Covid-19 Impact
Resolved
This incident has been resolved.
Posted Feb 24, 2022 - 16:41 PST
Monitoring
Please be advised that our Reno, NV site is currently experiencing labor staffing shortages due to confirmed Covid-19 cases. Currently the labor shortage is heavily impacting inbound receiving. We anticipate this labor shortage to impact receiving over the next few weeks. We will continue to monitor and provide updates.
Posted Jan 13, 2022 - 08:48 PST
This incident affected: Warehouses (Reno, NV).