Acceptance of Mail Destined to the Baghdad Airport
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 12:15 PDT
Monitoring
The Department of Defense Military Postal Service Agency has requested USPS to temporarily suspend mail acceptance for the postal ZIP Codes transiting through/destinating to the Baghdad Airport.

Zips to temporarily curtail acceptance in postal stream:

09305
09308
09333
09348
09378
09381
96610-0800
96610-1500

Until the suspension is lifted, shipping to these postal codes through the Shipwire Platform will be unavailable with USPS, FedEx Smartpost, and UPS Surepost carrier services.
Posted Jan 13, 2020 - 12:08 PST
This incident affected: Carriers (USPS).