Hurricane Michael Transportation Service Alerts
Resolved
This incident has been resolved.
Posted Oct 30, 2018 - 06:22 PDT
Monitoring
Hurricane Michael is causing disruption to parcel deliveries in the U.S. Check your carrier's website to understand if your customers may be impacted.

https://www.fedex.com/en-us/service-alerts.html
https://www.ups.com/us/en/service-alerts.page?id=alert1
https://mailsmartlogistics.com/hurricane-michael-usps-updates/
Posted Oct 10, 2018 - 16:30 PDT
This incident affected: Carriers (FedEx, UPS, USPS).