Purolator Network Delivery Delays
Resolved
This incident has been resolved.
Posted Jan 04, 2021 - 10:04 PST
Update
Purolator has not experienced any further issues with pickups over the last day. We will continue to update you as Purolator provides more information.
Posted Dec 09, 2020 - 14:26 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 08, 2020 - 13:45 PST
Monitoring
Due to high-shipment demand expected to continue through the upcoming holiday season, as well as health and safety measures to keep our people safe, we are making operational adjustments – including delivering residential shipments throughout weekends – to effectively service our customers. As such, all Purolator Ground® shipments will experience a delay of one to three days (inclusive of weekends) and shipments that require our Special Handling service will experience delays of four to seven days (inclusive of weekends).

Below is an update on shipment volumes and service impacts by province. Any delays noted below are over and above those created by our operational adjustments:

East:
• Newfoundland: Shipments across the province may experience a one-day delay as a result of ferry service interruptions.
• New Brunswick: Service is current.
• Nova Scotia: Shipments to Yarmouth may experience a one-day delay.
• Prince Edward Island: Shipments to Charlottetown may experience a one-day delay.
• Quebec: Shipments to Beauceville may experience a one-day delay.

Central:
• Ontario: Shipments to northern and southwestern Ontario may experience a one-day delay.

West:
• Manitoba: Shipments to Prince Albert and Winnipeg are currently experiencing a one to three day delay. Additionally, As a result of the government decision to temporarily close non-essential businesses in Manitoba, shipments destined to these closed business will be held for pickup for five business days and scanned as “Receiver unavailable - Temporary closure for pandemic” when customers track shipments.
• Saskatchewan: Purolator’s operations in Saskatchewan continue to recover from the recent winter storm, particularly in Regina and Saskatoon. Shipments may experience a one-day delay.
• Alberta: Shipments to Calgary, Lethbridge and Prince George may experience a one-day delay.
• British Columbia: The Richmond Hub experienced a mechanical issue late Thursday night. Shipments may experience a one-day delay.
Posted Nov 16, 2020 - 10:36 PST
This incident affected: Carriers (Canada Post, Purolator) and Warehouses (Mississauga, CAN, Richmond, CAN).