Reminder: U.S. Holiday Facility Closures for Independence Day
Resolved
This incident has been resolved.
Posted Jul 13, 2020 - 16:12 PDT
Monitoring
Please note that most U.S. warehouse facilities will be closed on July 3rd and 4th for Independence Day. A full list of warehouse closure dates is available on our website https://www.ingrammicroservices.com/peak/fulfillment-center-closures.
Posted Jun 25, 2020 - 13:34 PDT
This incident affected: Warehouses (Rancho Cucamonga, Mira Loma, CA, Carrollton, TX, Millington, TN, Carol Stream, IL, New Lenox, IL, Hermosa, CA).