FedEx Service Delays Across the U.S.
Resolved
This incident has been resolved.
Posted May 18, 2021 - 11:21 PDT
Monitoring
Due to an unprecedented volume of shipments out of the FedEx Memphis Hub, delays in deliveries across the U.S. may occur. We will continue to provide updates and keep you readily informed.
Posted May 05, 2021 - 11:13 PDT
This incident affected: Carriers (FedEx).