Delays due to Winter Storms in Reno
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted Feb 09, 2021 - 09:16 PST
Monitoring
Due to harsh weather conditions and labor shortages in Reno, NV, delays in shipping may occur. We will continue to monitor this situation and will update you accordingly.
Posted Jan 27, 2021 - 13:25 PST
This incident affected: Warehouses (Reno, NV).