Lancaster, PA Weather Delays 11/15
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted 2 months ago. Nov 20, 2018 - 15:30 PST
Monitoring
Lancaster, PA is experiencing delays due to inclement weather. Impacted orders will be shipped on Friday, 11/16.
Posted 2 months ago. Nov 15, 2018 - 13:21 PST