UPS Service Delays due to Severe Weather
Resolved
This incident has been resolved.
Posted Mar 09, 2021 - 10:29 PST
Update
Due to significant weather events across the U.S. on Saturday, 2/17/21, the UPS U.S. Network has been impacted. Please be advised that potential delivery delays may occur.

For the latest service updates and impacted zip codes, please go to https://www.ups.com/us/en/service-alerts.page?id=alert1.
Posted Mar 01, 2021 - 09:43 PST
Update
The ongoing significant weather events across the U.S. has continued to impact the UPS U.S. Network. Please continue to expect service delays for package deliveries.

For the latest service updates and impacted zip codes, please go to https://www.ups.com/us/en/service-alerts.page?id=alert1.
Posted Feb 22, 2021 - 10:38 PST
Update
With the ongoing weather events across the U.S., the UPS U.S. Network has continued to be impacted and service delays will occur through the end of the week.

For the latest service updates and impacted zip codes, please go to https://www.ups.com/us/en/service-alerts.page?id=alert1.
Posted Feb 17, 2021 - 10:49 PST
Update
Due to significant weather events across the U.S. on Saturday, 2/13/21, the UPS U.S. Network has been impacted. Please be advised that potential delivery delays may occur.

For the latest service updates and impacted zip codes, please go to https://www.ups.com/us/en/service-alerts.page?id=alert1.
Posted Feb 15, 2021 - 10:04 PST
Monitoring
UPS U.S. Air Network Service delays may occur due to severe weather in Louisville, KY and Philadelphia, PA areas. We are currently monitoring this situation and will continue to provide updates as more information becomes available.

For real-time service updates and impacted zip codes, please go to https://www.ups.com/us/en/service-alerts.page?id=alert1.
Posted Feb 11, 2021 - 09:26 PST
This incident affected: Warehouses (Millington, TN, Carol Stream, IL, New Lenox, IL, Lancaster, PA, Jonestown, PA) and Carriers (UPS).