StarTrack Industrial Action Planned on Oct 21, 2021
Resolved
This incident has been resolved.
Posted Nov 22, 2021 - 08:57 PST
Investigating
StarTrack will process Industrial Action planned on Oct 21, 2021. The following will be impacted:

• Australia Post is not impacted by this so their AP Express team will continue to support the ST Premium fleet during this time
• Delays for standard ground (EXP) and Premium deliveries are expected in some areas but ST is confident is will be minimal
• All freight out of IM picked up on Wednesday may not delivered on Thursday due to the strike. SLA will be pushed out to +1-2 days

For any questions or concerns please contact customercare@ingrammicroservices.com.
Posted Oct 20, 2021 - 11:12 PDT
This incident affected: Carriers (StarTrack).