Fulfillment Delays in Reno, NV and Lancaster, PA Fulfillment Centers
Resolved
This incident has been resolved.
Posted May 13, 2022 - 08:55 PDT
Identified
Please be advised that our warehouse systems in Reno, NV and Lancaster, PA are experiencing some outages due to a power outage, causing fulfillment delays. We expect the warehouse systems to be operational by this afternoon, but expect the fulfillment delays to likely run through the weekend. Thank you for your patience as we navigate this issue.
Posted May 04, 2022 - 10:41 PDT
This incident affected: Warehouses (Lancaster, PA, Reno, NV).