Printer Issue at the Tilburg, NLD Warehouse
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted 16 days ago. Oct 30, 2018 - 06:26 PDT
Identified
At the Tilburg, NLD Warehouse, we are investigating a printer issue which is affecting the legibility of Commercial Invoices. Outbound shipments requiring Commercial Invoices may be delayed. We apologize for any inconvenience this may have caused.

For any questions or concerns, please contact customercare@ingrammicrocommerce.com
Posted 3 months ago. Aug 30, 2018 - 13:11 PDT
This incident affected: Warehouses (Tilburg, NLD).