Daventry_ GBR - Royal Mail Int'l Unavailable until Further Notice
Resolved
This incident has been resolved.
Posted Jun 01, 2022 - 10:36 PDT
Monitoring
March 24, 2022

Royal Mail Int'l service is currently suspend from Daventry due to system upgrade, ETA will update accordingly.
Alternative options would be Parcel Force or ABM Parcel Lite services until then.

If you have any questions, please contact customercare@ingrammicroservices.com.
Posted Mar 24, 2022 - 10:08 PDT
This incident affected: Carriers (Royal Mail).