Hurricane Ian - Florida Service Interruptions
Resolved
This incident has been resolved.
Posted Dec 01, 2022 - 09:19 PST
Update
FedEx is now conducting standard daily operations in most areas that were recently affected by Hurricane Ian. Some areas in Florida will continue to have service disruptions due to the heightened impacts of Hurricane Ian. Our thoughts are with those affected.

Service delays and disruptions can be anticipated for inbound and outbound shipments throughout the following zip codes:

33924 Captiva, FL
33957 Sanibel, FL
FedEx Express, FedEx Ground, FedEx Freight, FedEx Office, etc. as well as cities, states and ZIP Codes serviced may be affected differently
Posted Nov 03, 2022 - 15:09 PDT
Update
FedEx is now conducting standard daily operations in most areas that were recently affected by Hurricane Ian. The Fort Myers market in Florida will continue to have service disruptions due to the heightened impacts of Hurricane Ian in that area.

Service delays and disruptions can be anticipated for inbound and outbound shipments throughout the following zip codes:

33924 Captiva, FL
33957 Sanibel, FL
33931 Ft Myers Beach, FL
FedEx Express, FedEx Ground, FedEx Freight, FedEx Office, etc. as well as cities, states, and ZIP Codes serviced may be affected differently.
Posted Oct 25, 2022 - 14:11 PDT
Update
FedEx is now conducting standard daily operations in most areas that were recently affected by Hurricane Ian. The Fort Myers market in Florida will continue to have service disruptions due to the heightened impacts of Hurricane Ian in that area. Service delays and disruptions can be anticipated for inbound and outbound shipments throughout the following zip codes:

33924 Captiva, FL
33957 Sanibel, FL
33931 Ft Myers Beach, FL
33956 St James City, FL

FedEx Express, FedEx Ground, FedEx Freight, FedEx Office, etc. as well as cities, states, and ZIP Codes serviced may be affected differently.
Posted Oct 19, 2022 - 10:09 PDT
Update
We are continuing to monitor for any further issues.
Posted Oct 04, 2022 - 15:54 PDT
Update
All USPS, UPSMI, and Pitney Bowes orders are being released to be processed. Please note that some deliveries for FedEx and UPS are still on hold due to the hurricane.
Posted Oct 04, 2022 - 15:53 PDT
Monitoring
Please be advised that many carrier services will be temporarily suspended and/or limited in southern Florida. This includes:

FedEx Ground: limited services
FedEx Express: All Overnight, Express, and 3-day services
UPS: All Parcel Services
UPSMI, Pitney, and USPS: All services.
Posted Sep 28, 2022 - 15:47 PDT
This incident affected: Carriers (FedEx, UPS, USPS).