Daventry, UK order delay
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 12:11 PDT
Monitoring
Yesterday an issue with a system in our Daventry, UK warehouse caused a backlog on some orders, impacting 35 clients. While the issue has been resolved, it may cause a delay in some orders shipping. We apologize for any inconvenience this may cause, and thank you for your patience. For any questions or concerns, please contact customercare@ingrammicroservices.com.
Posted Aug 29, 2019 - 08:11 PDT
This incident affected: Warehouses (Daventry, GBR).