USPS Network Disruptions and Service Delays
Resolved
This incident has been resolved.
Posted Mar 09, 2021 - 10:29 PST
Update
Due to the ongoing weather events throughout the U.S., the USPS Network has continued to be impacted and is currently experiencing increased mail volumes. Please continue to expect USPS service delays for package deliveries.

For the latest service alerts, location-specific disruptions, and impacted zip codes, please go to https://about.usps.com/newsroom/service-alerts/business/welcome.htm.
Posted Feb 22, 2021 - 10:41 PST
Monitoring
The recent and ongoing weather events across the U.S. have significantly impacted the USPS Network. Due to the recent events and unprecedented mail volumes, please expect USPS service delays at this time.

For the latest service alerts, location-specific disruptions, and impacted zip codes, please go to https://about.usps.com/newsroom/service-alerts/business/welcome.htm.
Posted Feb 17, 2021 - 10:50 PST
This incident affected: Warehouses (Rancho Cucamonga, Mira Loma, CA, Carrollton, TX, Millington, TN, Carol Stream, IL, New Lenox, IL, Lancaster, PA, Jonestown, PA, Reno, NV) and Carriers (USPS).