Receiving Delays: Lancaster, PA
Resolved
This incident has been resolved.
Posted Dec 28, 2021 - 08:34 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 28, 2021 - 08:34 PST
Monitoring
Please be advised that our Lancaster, PA facility is currently experiencing delays for inbound receiving which is outside of our 2 day SLA. The current lead time is approximately three weeks for inbounds to be received.

We expect inbound receiving delays to continue as we go into peak season and lasting through our inbound blackout date of Monday, November 15th.

We apologize for any inconvenience this may be causing. For any questions or concerns please contact customercare@ingrammicroservices.com.
Posted Oct 25, 2021 - 14:47 PDT
This incident affected: Warehouses (Lancaster, PA).