Weather Updates - Service Disruption
Resolved
This incident has been resolved.
Posted Feb 14, 2023 - 14:09 PST
Identified
Thursday, February 2, 2023

Fedex
FedEx Express experienced substantial disruptions at Memphis and Dallas/ Ft. Worth hubs last night due to severe winter weather. Potential delays are possible for package deliveries across the U.S. with a delivery commitment of Thursday, February 2, 2023.
There may be different levels of impact depending on city, states and Zip code serviced. Please find more detail from below link.
https://www.fedex.com/content/dam/fedex/us-united-states/Service-Alerts/images/2023/q3/OSD_02_02_23.xlsx

UPS
Weather conditions in Texas may cause package delays. UPS would ensure that shipments arrive at their final destinations as quickly as conditions permit.


If you have any questions, please contact customercare@shipwire.com.
Posted Feb 02, 2023 - 09:39 PST
This incident affected: Carriers (FedEx, UPS).