Daventry, UK warehouse processing delays for order and ASN exceptions
Resolved
This incident has been resolved.
Posted Mar 12, 2020 - 12:15 PDT
Identified
Due to a few system and staffing limitations pertaining to the Daventry, UK warehouse, we have unfortunately encountered delays in processing ASN and order exceptions. Within the next 6 weeks, we plan to resolve the system issues for a permanent fix. In the meanwhile, we also are putting in place stronger processes and additional staff to manage order exceptions for faster resolution. For further questions, please contact customercare@ingrammicroservices.com.
Posted Sep 09, 2019 - 12:46 PDT
This incident affected: Warehouses (Daventry, GBR).