FedEx Service Delays Across the U.S.
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted Apr 06, 2021 - 15:17 PDT
Update
Severe weather events across the U.S. are continuing to impact FedEx operations. Please expect delays in deliveries.

For impacted cities, states, and zipcodes, please refer here: https://www.fedex.com/content/dam/fedex/us-united-states/Service-Alerts/images/2021/q4/FedEx_Service_Update_2021-03-18_PM_Winter_Storms_vf.xlsx
Posted Mar 19, 2021 - 10:56 PDT
Monitoring
Due to harsh weather events across the Plains, FedEx has been operationally affected. Service delays may occur in impacted areas.

For impacted cities, states, and zipcodes, please refer here: https://www.fedex.com/content/dam/fedex/us-united-states/Service-Alerts/images/2021/q4/FedEx_Service_Update_2021-03-17_PM_Winter_Storms_vf.xlsx
Posted Mar 18, 2021 - 10:01 PDT
This incident affected: Carriers (FedEx).