Delayed response to Customer Care inquiries
Incident Report for Shipwire
Resolved
This incident has been resolved.
Posted 23 days ago. Jun 26, 2019 - 10:11 PDT
Identified
We are currently experiencing delayed response times to inquiries sent to our customer support email.
For questions or concerns, please continue to contact customercare@ingrammicroservices.com or call 1-888-744-7947, option 1.

If you do not receive a response to an inquiry after 24 hours, please contact CustomerCareEscalations@ingrammicro.com
Posted 5 months ago. Feb 20, 2019 - 12:36 PST
This incident affected: Merchant portal (Dashboard, Merchant Application).