Fulfillment Center Schedule Due to Weather Condition
Resolved
This incident has been resolved.
Posted Sep 11, 2023 - 11:02 PDT
Monitoring
Sep 1 2023

The Shenzhen warehouse will be closed today (09/01) due the impact of the typhoon. All orders fulfillment will be postponed to Monday (09/04).

We apologize for any inconvenience this may be causing. For any questions or concerns please contact customercare@shipwire.com.
Posted Sep 01, 2023 - 10:13 PDT
This incident affected: Warehouses (Shenzhen, CHN).